Home 

Windows Live Essentials 2011 and Windows Update… can break your reference image

[Edit 03/11/2011] Hotfix KB981542 fixed this problem. Service Pack 1 for Windows 7 also resolves the problem.

I’ve tried to assist someone on the TechNet forums who was getting an error once he had created his reference image to his wishes and
ran sysprep to use it for further deployments and then try to boot into it. Here’s the link to the topic on TechNet;

http://social.technet.microsoft.com/Forums/en-US/w7itproinstall/thread/88fd6905-0454-4db0-ab5f-3718b640fbb5

The error looks like this (if you let it reboot, it will just come up again, over and over):

Windows could not finish configuring the system. To attempt to resume configuration, restart the computer.

We both realized quite soon that it had something to do with Live Essentials 2011, so I went to test a lot…

I think I’ve done about 5 installs of windows, clean installs, one of my old images that I have at my
test deployment environment at home and images that we ship out to ourcustomers,
I loaded all of these in VM’s and ran sysprep around 30 times, it starts to get old.. fast

At first I could not trigger the issue at my work pc’s, and the reason for that is because I don’t need to generalize the pc’s there (unless we
have a large order for a company). As soon as I manually ran sysprep with the generalize option, I was getting exactly the same error.
This was an image that I built in early July right after the Office 2010 OPK was released. It contained most updates up to this date Live Essentials 2010 and Office 2010 Starter.
If I ran sysprep /generalize right after the deployment of this image, without letting it self update and install WLE2011 there was no error.
I then ran WLE2011 to update the 2010 programs, and tried again and the image was still ok.
However, after applying the more recent updates after WLE2011 was installed on the machine, and I’d try to sysprep /generalize the error would be there!

It’s really simple to recreate this error, pick any flavor of Windows 7, x86 or x64, Starter all the way through Ultimate/Enterprise, they will all do the trick.
Do a clean rtm install, install WLE2011, either through WU (this will download the executable of 160mb containing the everything),
or download the web-dl installer from the WLE site, or install it through the OPK and then lastly run all the windows updates.
Once that is all done, sysprep your pc with the generalize option, and the error will be there.

Next I’ll list all the various combinations that will trigger this error, and what does not. And at the end of all this, I’ll provide you with a solution.
The error can appear if you fulfill any of these requirements.

Applies to any version of Windows 7 (I did not test this on Vista)

  • It will not  matter which WLE2011 installer you use; whether it’s the OPK, wlsetup-all.exe or wlsetup-web.exe results are the same.
  • The error applies to any particular part of WLE2011, it’s not just one component as soon as any component has been installed, or all you become eligible for this problem.
  • If you have this problem, and have already installed WLE2011 prior to running Windows Update, it will not solve the problem by simply uninstalling WLE2011.
    As soon as it has been installed, and still have updates to install, then
    you’re out of luck.
  • Only updates that require you to reboot your pc, will cause the error.

The error will not show up if you do not generalize your
image.

At least there is a solution, [cut] apply the appropiate hotfix or sp1.

 

Leave a Reply